The KCLS Tech Tutor Program offers free One-on-One Computer Help and Computer Classes. Go to kcls.org/techtutor for upcoming Tech Tutor sessions, learning online and class manuals. This manual is for Microsoft Excel 2013 – Level 3 classes held on KCLS computers running Windows 7.

Contents

Signing In to Library Computers ................................................................................................................................. 1

In this class, you will....................................................................................................................................................... 2

More Helpful Tools in Excel 2013 ............................................................................................................................... 2

Converting Text to Columns .......................................................................................................................................... 2

Conditional Formatting .................................................................................................................................................... 3

Using Count & Countif Functions ............................................................................................................................... 3

Removing Duplicates .................................................................................................................................................... 5

Sheet Protection ............................................................................................................................................................. 6

The Excel Table Feature ............................................................................................................................................... 6

Pivot Tables ................................................................................................................................................................. 7

Create a Pivot Table ..................................................................................................................................................... 7

Using the Pivot Table .................................................................................................................................................. 9

More Computer Learning from KCLS ......................................................................................................................... 11

---

**Signing In to Library Computers**

For personal use of library computers, sign in with your library card number and Personal ID number.

**For a computer class, sign in with these codes:**

- 627837
- 1212

**Note:** Be careful not to type the letter “O” for a zero (0) or the letter “l” for a one (1).
In this class, you will...
- Learn more helpful tools and functions in Excel 2013
- Begin working with Pivot Tables

You may review Excel 2013 basics at kcls.org/techtutor: select Excel Level 1 or Level 2 from the drop-down menu of classes and click “Manual”, explore learning online resources, or both.

More Helpful Tools in Excel 2013

Converting Text to Columns

Converting text to columns is very useful in Excel. For example, if you have a list with first and last names in a single cell, separating the names into separate cells will make the data easier to work with when searching, filtering or editing. Let’s learn to use the text to columns command in the data tab:

To get the training exercise file:
1. Go to kcls.org/techtutor
2. Click “select a class” button under “English”
3. Select Excel Level 3 from the drop-down menu
4. Click “Training Exercise” to open
5. Click “Absolute” tab at bottom of workbook

Here’s how to use the convert text to columns wizard (Figure 1):
1. Click Text.Columns tab in the Excel Level 3 workbook (bottom tabs)
2. Insert a blank column
   a. Click column C label
   b. Right-click in column C
   c. Click Insert to insert a blank column
3. Select source column
   a. Click the column B label
4. Click Data tab in the Ribbon
5. Click Text to Columns command
6. Select “Delimited,” click next
7. Select delimiter (e.g., space), click Next
8. Confirm Data Preview
9. Click Finish
10. Click OK

Now try converting the text in the City/State column. Follow all previous steps, but step 7 will require multiple delimiters. Which additional delimiter must you use to separate “City/State”?
Conditional Formatting

Conditional formatting is great for formatting a cell(s)—like, changing font or fill color—based on criteria or rules you set. For example, an employee at a construction company had a $9800 monthly budget for purchases last year. Her boss wants to know how many months last year she went over budget. Using conditional formatting in Excel makes it easy to show this information.

Here’s how to create a new rule for conditional formatting (Figure 2):
1. Click Conditional Formatting tab in the Excel Level 3 workbook (bottom tabs)
2. Select cell range B1:B12
3. From the Home tab, under Styles group, click the Conditional Formatting command
4. Click “New Rule”
5. Select “Format only cells that contain”
6. Select “greater than” from the second drop down menu
7. Type 9800 in the blank field to the right
8. Format fill color
   a. Click format button in dialog box
   b. Click Fill tab in dialog box
   c. Choose desired color
   d. Click OK
9. Click OK in New Formatting Rule dialog box

Now use conditional formatting to find out which weeks during first quarter (January through March) she spent under (less than) her $2450 weekly budget. Reminder: select multiple cells and cell ranges by pressing the Ctrl key while clicking cells.

Using Count & Countif Functions

The Count function in Excel is used for reliably counting entries in a selected range of cells, usually a column. This function saves time and prevents errors from manually counting items. For example, the shipping department of ABC Company needs to know how many customer orders have required delivery dates (Figure 3, column K) to prioritize workflow and assure timely delivery. We will use the count function to find this answer.

<table>
<thead>
<tr>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>City</td>
<td>Region</td>
<td>PostalCode</td>
<td>Country</td>
<td>RequiredDate</td>
</tr>
<tr>
<td>St Louis</td>
<td>MO</td>
<td>69203</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>Boston</td>
<td>MA</td>
<td>02137</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>Westover</td>
<td>WV</td>
<td>26964</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>Auburn</td>
<td>WA</td>
<td>39823</td>
<td>USA</td>
<td>1/12/2007</td>
</tr>
<tr>
<td>Seattle</td>
<td>WA</td>
<td>12345</td>
<td>USA</td>
<td>1/12/2007</td>
</tr>
<tr>
<td>Moscow</td>
<td>ID</td>
<td>20512</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>Helena</td>
<td>MT</td>
<td>62665</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>Seattle</td>
<td>WA</td>
<td>01233</td>
<td>USA</td>
<td></td>
</tr>
</tbody>
</table>

Figure 3 – The count function counts how many cells, like in column K, have a value. The countif function counts how many cells, like in column H, meet criteria such as contain “WA”.

Figure 2 – Select Rule Type and Edit the Rule Description in this dialog box.
Here’s how to use the COUNT function:
1. Click the Count Filter tab in the Excel Level 3 workbook (bottom tabs)
2. From the View tab, click the Freeze Panes command and choose “Freeze Top Row”
3. Click into cell K89
4. From the Formulas tab, click Insert Function
5. Select COUNT function, then click OK
6. In the Value 1 field, type the cell range you want to count; in this case K2:K88 (Figure 4)
7. Click OK

The cell will display the number of orders that have required delivery date.

The COUNTIF function is great for counting an entry if it meets certain criteria. For example, the shipping company is short on drivers in Washington and must determine how many orders are for delivery in that state. We’ll count orders only if they are to be delivered in “WA” (Figure 3, column H).

Here’s how to use the COUNTIF function:
1. Click into cell H89
2. From the Formulas tab, click Insert Function
3. Type “countif” in the search box (Figure 5), then click Go
4. Make sure COUNTIF is selected in list, then click OK
5. Type the cell range you want to count—in this case H2:H88 (Figure 6)
6. Type “WA” (with quote marks) in the Criteria box (Figure 6), then click OK

The cell will display the number of orders that match the “WA” criteria in column H.
Removing Duplicates

Sometimes a large spreadsheet may have duplicate rows. This usually occurs when more than one person enters data into a shared worksheet. It would be very tedious to manually find and remove duplicates from a couple hundred rows. Let’s learn about using the **Remove Duplicates** command.

**Here’s how to use the Remove Duplicates command:**

1. Click the **Duplicates** tab in the *Excel Level 3* workbook (bottom tabs)
2. Select **Data** tab
3. Highlight all data in table
4. Click “Remove Duplicates”
5. Confirm “My data has headers” is checked (**Figure 9**)
6. Click “Select All” button (**Figure 9**)
7. Click OK

![Figure 9](image)

**Figure 9** – Check *My data has headers* box and select all columns in this box.

![Figure 9.5](image)

**Figure 9.5** – a dialog box will indicate how many values were found and will be removed, and how many unique values remain.
Sheet Protection

Password protect your worksheets so your work is not modified by unauthorized persons.

Here’s how to protect a sheet:
1. Click the January tab in the Excel Level 3 workbook (look toward bottom tabs)
2. Select Review tab in the Ribbon
3. Click Protect Sheet (Figure 10)
4. Enter password 123, then click OK
5. Re-type your password to confirm
6. Try to change cell B7 to 30,000

Note: To remove protection, click Unprotect Sheet in the Review tab and enter password.

The Excel Table Feature

The Excel 2013 table feature converts a list of data into a formatted table. Tables are used for sorting and filtering data, and help organize and view information easily. An Excel table is an excellent tool for a pivot table, which allows you to quickly summarize and analyze large amounts of data, and easily extract information without using formulas.

Before creating an Excel table, and especially for a pivot table, it is important to adhere to the following standards (Figure 11):
- Organize data in rows and columns in a spreadsheet
- Apply one type of data for each row and column
- Include a unique, descriptive header in the top row of the table for each column
- For each row, include one unique record of data about a particular entity or transaction
- Avoid blank rows or columns, including first row after header
- Use a zero instead of a blank cell in the table
- Keep list of data contained in worksheet

Figure 10 – Create a password in the Protect Sheet dialog box.

Figure 11 – A well-formatted list of data has clear headers and information in neat rows and columns.
Here’s how to create an Excel table:
1. Click the Excel table tab in the Excel Level 3 workbook (bottom tabs)
2. Click into any cell in your list of data
3. Click Insert tab in the Ribbon
4. Click the Table command
5. Confirm cell range and “My table has headers” box is checked in Create Table dialog box (Figure 12)
6. Click OK

The worksheet is now an Excel table. Here are some useful tips for using tables:
- The heading cells have drop down arrows for sorting or filtering data (see Filter Function, p. 3)
- Any time you click within the table, the Table Tools Design tab appears at the end of the Ribbon
- Change table styles in the Table Tools Design tab
- Rename your table in the Properties group of the Table Tools Design tab
- Click Convert to Range command in Table Tools Design tab to revert to a normal range of data

Pivot Tables
A pivot table is an interactive table that allows you to group and summarize large amounts of data in a concise table. Sort, hide, count and add data to reveal patterns and trends and make data reporting and analysis easier. In this section, we will learn how to create a pivot table and some important terms.

Create a Pivot Table
1. Click the Sales List tab in the Excel Level 3 workbook (bottom tabs)
2. Click into any cell in the worksheet
3. On the Insert tab click the Pivot Table command
   
   Note: A Create Pivot Table dialog box appears (Figure 13). Excel identifies table range by finding the worksheet edge (blank row and column). Do not change the default setting, “New Worksheet”.
4. Click OK

---

1 From The Spreadsheet Page: http://spreadsheetpage.com/index.php/file/pivot_table_demo_workbook
A skeleton structure of your pivot table appears in a new worksheet (Figure 14). The three main areas in the structure are the actual pivot table area (A); the pivot table Field List area (B), which is a listing of all the fields in the worksheet; and the pivot table Layout Areas (C), individual components that make up the pivot table (Report Filter, Column Labels, Row Labels, and Values).

To build a pivot table report, you will need to drag a field name from the top of the pivot table field list to one of the drop areas at the bottom of the pivot table field list. Each field has a check mark control to its left to help you add column data to the pivot table or remove it. You need at least 2 fields in a pivot table report (a row/data field and a data field), but using 3 fields (a row field, a column field, and a data field) is popular.

**Important pivot table terms to know:**

**Data field:** A field from the source worksheet that contains values to be summarized. For example, Sum of Sales is a data field.

**Report filter:** Data fields in this area act as filters for the pivot table report. For example, if you add the Year field from a table as a report filter, you can display data by all or individual years in the table.

**Column labels:** Data fields in this area determine the arrangement of data shown in the columns of the pivot table.

**Row labels:** Data fields in this area determine the arrangement of data shown in the rows of the pivot table.

**Values:** Data fields in this area determine which data are presented in the cells of the pivot table—they are the values that are summarized in its last column (totaled by default).

**Page field:** A field from the source data that you assign to a page (or filter) orientation in a pivot table report.

**Column field:** A field from the source data that you assign to a column orientation in a pivot table report. For example, Type is a column field.

**Item:** A subcategory of a row, column, or page field.

**Row field:** A field from the source data that you assign to a row orientation in a pivot table report. For example, Region and Salesperson are row fields.

**Data area:** The cells in a pivot table report that contain summarized data.
Using the Pivot Table

When you create a pivot table, worksheet column headers become movable data fields. It is important to understand what the headers represent to work with the data fields in the pivot table report. The worksheet we used to create a pivot table, Sales List, shows information on an individual’s referral sales in 2009 (Figure 15). The product line header describes the type of product or category; item name is the actual name of the product; price is the retail price; referral fee rate is the percentage of the price the individual earns for each unit sold; and referral fee rate2 describes how many times the rate is applied based on number of units sold.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Product Line</td>
<td>Item Name</td>
<td>ASIN</td>
<td>Seller</td>
<td>Date Shipped</td>
<td>Price ($)</td>
<td>Referral Fee Rate</td>
<td>Referral Fee Rate2 ($)</td>
<td>Revenue ($)</td>
<td>Referral Fees ($)</td>
</tr>
<tr>
<td>2</td>
<td>Health &amp; Personal Care</td>
<td>Colon Cleanse Laxative - 50 Capsules</td>
<td>80005/SYNW</td>
<td>Third Party</td>
<td>29-May-09</td>
<td>$18.09</td>
<td>7.02%</td>
<td>1</td>
<td>$18.09</td>
<td>$1.27</td>
</tr>
</tbody>
</table>

Figure 15 – One row from the Sales List worksheet showing sales data for 2009.

We will use the pivot table to find out which product line had the most units sold, in 2009.

Here’s how to find out which item type had the most units sold in 2009:

1. Click into Sheet 1 in the Excel Level 4 workbook (bottom tabs)
2. Check box next to Product Line in the pivot table field list area (Figure 14) first
   
   **Note:** If you check the box for a text field, the pivot table automatically adds that field to the Rows Labels drop area (Figure 16).
3. Check box next to Item Name
4. Check box next to Referral Fee Rate2 item
   
   **Note:** If you check the box for a numeric field, pivot table automatically sums that field in the Values drop area (Figure 16).

You now have your first pivot table report (Figure 17). Remember, when we clicked referral fee rate2 in the pivot table field list the sum of that field was automatically added to the Values drop area (Figure 16). So the sums in that column correspond to the row labels, which are product line, or item type, broken down into individual item name. We need to further modify the pivot table report to more easily get the answer to our question.

Figure 16 – Data fields are automatically added to drop areas, but can be rearranged by clicking and dragging as needed.
We only need the sum of the **Product Line**, or item type to know which item type had the most units sold in 2009, so we will collapse the entire row label field (Figure 18).

**Here’s how to collapse the row label field:**
1. Right click on a **Product Line** (notice the minus sign to the left of the name)
2. Move cursor over “Expand/Collapse” without clicking
3. Move into sub menu
4. Click “Collapse Entire Field”

The pivot table report appears like Figure 19. It’s easier to read and answer our questions of which **Product Line** (row label) has the highest value in the **sum of referral rate2** column. This answers our question of which product line had the most units sold in 2009 because **referral fee rate2** column describes how many times the rate was applied based on number of units sold (Figure 15).

**Note:** Alternatively, we could have achieved the same pivot table report view by excluding the item name field in the row label drop area (Figure 16). This exercise also gives overall familiarity to the mechanics of pivot tables.

**✓ TIP:** If you click outside the pivot table, the **pivot table Field List** is hidden. When you click into the pivot table, the **pivot table Field List** is again displayed. You may turn off the display of the **pivot table Field List** by clicking the X in the upper right-hand corner. You can redisplay it by clicking the Options tab in the **pivot table Tools** ribbon menu and selecting the **Field List** command in the Show/Hide group.

Figure 17 – Pivot table report with product line and item name as row labels, sum of referral rate2 as a value.

Figure 18 – Pivot table report with product line and item name as row labels, sum of referral rate2 as a value.

Figure 19 – Collapsed row label view of pivot table report.
More Computer Learning from KCLS
The KCLS Tech Tutor Program offers free One-on-One Computer Help and Computer Classes. Go to kcls.org/techtutor for upcoming Tech Tutor sessions, computer learning online courses through premium databases and class manuals. This manual has been for Microsoft Excel 2013 — Level 3 class held on library computers running Windows 7.

Please visit kcls.org/usingthelibrary/computers/ to learn more about using KCLS library computers.

— END —